Browser-based error messages

  • 404 browser error: The page you are trying to access is not found. Or, in the AlphaLB.toml configuration, the line "rule" under [frontends.xxx] does not include the domain(s) expected to hit the website. The example below shows the frontend expects hits from the two domains listed.


rule = "Host: alphatogo.com,www.alphatogo.com"



  • Service Unavailable: The load balancer is running but there are no Alpha Instances running, or all of the Instances are 'down' due to the Health Check process is determining they are responding slower than allowed. The Health check monitor requires a response within 5 seconds. Remedy: Try to determine why your application is responding slowly; it may be poor Internet speed or poor application design. If your application constantly responds so slowly that the health check monitor believes the Alpha Instance is not responding, the only remedy is to fix your application or turn off health check so that the load balancer does not take your Alpha instances off-line.

  • Bad Gateway: This almost always means one or more of your Alpha Instance(s) are off-line (stopped) while the load balancer is running. Typical immediate solution is to restart the load balancer (this does not affect your Alpha users.) If you have multiple Alpha Instances running it is very possible that only one of your Alpha Instances is displayin Bad Gateway to your users and the other Instances are running fine. A possible solution is to use AlwaysUp to delay the start of the load balancer by enough time to allow Alpha to start; 60-120 seconds should suffice (check the Startup Tab in AlwaysUp for the load balancer.)

  • Bad Gateway 2: If you get this message in your browser right after you reboot your computer, then here is a trick that will help eliminate this. Open AlwaysUp and right-click on the AlphaLB record. Select the Startup tab. Check Ensure that the Windows networking components have started. If that does not fix the problem, check Ensure that the following services have started. In the list of checkboxes, find at least one of the Alpha Instances that you always want to start, and check that. You can check just one, or all of the Alpha Instances.


  • No response at all or "site cannot be reached" message: typically means your load balancer is not running or has not been started.


AlphaLB InfoFile-based error messages

  • The requested address not valid in context: this means the IP you have provided in the configuration file is incorrect or not found in the server.  

  • CANNOT START - Servers found in configuration: x. Servers allowed by license: y.: If this message appears in your InfoLog it means you have configured more Alpha Instances than your license allows. Please contact AlphaToGo if you want to increase the number of Alpha Instances you can support.

  • CANNOT START - License is missing or invalid. Check the configuration file.: Similar to above, the License Number is missing or entered incorrectly in the configuration file.


Going back to No Load Balancer

  • It is easy to disable the load balancer and go back to how your system was set up prior to using the load balancer. Just disable the load balancer, and stop all of the Alpha Instances you started for the load balancer, and start up the original Alpha Instance, typically on port 80 or port 443.